Una vez que iniciamos con el uso de hojas electrónicas, se nos hace más fácil realizar tareas haciendo cálculos y automatizando muchas tareas que una herramienta como Microsoft Excel nos permite, pero no es sólo con temas matemáticos que este software nos facilita, sino que también con la aplicación de algoritmos sin la necesidad de recurrir a la programación VBA de Microsoft Office, y en este artículo les mostramos cómo aprovechar una función de búsqueda aplicada a una determinada lista.

Pongámonos en la situación de que tenemos que realizar un recibo o factura en la cuál ya contamos con una lista de conceptos pre definidos para exponerlos en el documento, cuya tarea es sencilla si contamos con una cantidad menor a 10 conceptos o productos, pero cuando supera esta cantidad, la actividad se torna más complicada y tal vez la mejor solución sea escribir los conceptos de forma manual sin recurrir a la lista pre definida.

Para el manejo de listas bien definidas y de una forma metódica, la mejor práctica es codificar la lista, es decir que deberemos asignar un código a cada ítem de la lista, un ejemplo claro son los supermercados, en los que cada producto tiene un código que incluso tiene inscrito el respectivo código de barras para que los dispositivos en cada caja sean leídos de forma automática sin necesidad de escribirlos manualmente.

El objetivo de este ejemplo será escribir el código de un ítem, y mediante la función BuscarV obtendremos la descripción del ítem del código escrito.

Empezaremos el ejemplo con la creación de un libro Excel, a continuación deberemos crear una lista de 10 productos, utilizando las columnas A y B, de tal forma que quede de la siguiente manera:

 

Para aplicar la función, registraremos la siguiente fórmula en la celda B12: =BUSCARV(A12; A1:B10; 2; FALSO)

Como referencia, los parámetros de la función BUSCARV son como sigue:

  1. Valor buscado.
  2. Matriz de búsqueda, dónde, en la primera columna debe estar el valor buscado.
  3. Columna de la matriz cuyo valor será devuelto en caso de encontrar el valor buscado (primer parámetro).
  4. Tipo de coincidencia en la búsqueda:
    1. VERDADERO: Coincidencia aproximada, en caso de que la lista esté ordenada.
    2. FALSO: Coincidencia exacta, en caso de que la lista no esté ordenada (valor recomendado).

NOTA: Es importante aclarar que para la separación de parámetros en las funciones de Microsoft Excel, Microsoft Office toma en cuenta la configuración regional  de separación de listas, en el ejemplo hemos tomado como separador de listas el símbolo ; (símbolo punto y coma), y deberá ser cambiado por el símbolo con el que esté configurado el equipo donde se esté aplicando el ejercicio, por ejemplo si el separador de listas configurado es , (símbolo coma), la fórmula deberá ser cambiada por la siguiente: =BUSCARV(A12, A1:B10, 2, FALSO)

Para completar el ejercicio, consignaremos en la celda A12 el valor 5, y cuyo resultado en la celda B12 será “Producto E”, y podremos probar con un número del 1 al 10 para ver el resultado respectivo.

Para un ejemplo más práctico, tomamos como base una plantilla denominada “Factura Simple” que tiene Microsoft Office, en cuyo detalle hemos añadido la función BuscarV, y con la sólo escribir el código del producto (lista incluida en una hoja adicional, con códigos del P001 al P999), se puede apreciar que automáticamente se visualizan la descripción del producto y el precio unitario para el cálculo automático de la venta. La hoja electrónica ejemplo se denomina factura01, y puede bajar el archivo haciendo clic aquí.

Acerca del autor

Julio César Peñafiel Bravo

Julio César Peñafiel Bravo

CEO Director de TIC Soluciones S.R.L. En constante aprendizaje de nuevas TIC's en general, geek, programador .NET, Android y Joomla, envíame un correo electrónico a Esta dirección de correo electrónico está protegida contra spambots. Necesita activar JavaScript para visualizarla..

¿Qué piensas?

¡Envíanos tus comentarios!